Issues creating new accounts

Incident Report for SimpleTexting

Resolved

We are happy to report our engineering team has resolved all issues affecting free-trial accounts.

Some users who registered yesterday (6/24/26), may need the help of our support team to create a new trial account to continue trying out SimpleTexting. If your account is affected, you'll receive an email this afternoon. We apologize for the inconvenience this caused.
Posted Jun 25, 2026 - 15:25 EDT

Monitoring

Issues preventing registration of new SimpleTexting free-trial accounts have been resolved.

We are still investing an issue affecting inbound and outbound messaging on existing free-trial accounts. We will provide an update as progress is made on resolving this issue.

Thank you for your patience!
Posted Jun 24, 2026 - 12:52 EDT

Identified

The issue impacting account creation and issues to existing free-trial accounts has been identified. A fix is currently being implemented by our engineering team.
Posted Jun 24, 2026 - 11:23 EDT

Investigating

Users have reported issues with creating new SimpleTexting accounts and accessing their previously created free-trials. We are currently looking into the cause and scope of this issue. We hope to have the system fully operational as soon as possible.
Posted Jun 24, 2026 - 10:20 EDT
This incident affected: Login.